You are not logged in.

#1 2016-04-10 12:15:05

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

[SOLVED] Small screen size on virtual machine

Hi guys

I'm running Bunsen on an ESXi system. Problem's the same as here - on startup screen reso is 800x600.

xrandr output:

Screen 0: minimum 1 x 1, current 800 x 600, maximum 8192 x 8192
Virtual1 connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600       60.00*+  60.32  
   1360x768      60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x768      59.87  
   1024x768      60.00  
   640x480       59.94  
Virtual2 disconnected (normal left inverted right x axis y axis)
Virtual3 disconnected (normal left inverted right x axis y axis)
Virtual4 disconnected (normal left inverted right x axis y axis)
Virtual5 disconnected (normal left inverted right x axis y axis)
Virtual6 disconnected (normal left inverted right x axis y axis)
Virtual7 disconnected (normal left inverted right x axis y axis)
Virtual8 disconnected (normal left inverted right x axis y axis)

Following damo's advise I created bl-screen.sh which I added to .config/openbox/autostart:

#!/bin/sh
xrandr --output VGA-0 --mode 1158x864 0x0 --rotate normal

As xrandr output shows I'm using Virtual1, I tried also VGA-1 on the script. No help. Next I tried creating a .desktop file in /etc/xdg/autostart as per this thread:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Categories=System
Terminal=false
Icon=
Name=Screensettings
Exec=/bin/bl-screen.sh
Comment=Autostart with 1158x864 resolution

It's not a huge issue, as I'm mostly SSHing into the system and manipulating RADIUS, DHCP, DNS etc. on CLI and changing the reso with ArandR works just fine. However I'd like to get this (too) sorted... so where do I need to look next?

Last edited by Peregrino69 (2016-04-10 16:35:53)

Offline

#2 2016-04-10 12:29:44

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Small screen size on virtual machine

Does this command work:

xrandr --output Virtual1 --mode 1158x864

It's probably best to set the screen resolution via /etc/X11/xorg.conf.d as this will also affect LightDM wink

For example:

# /etc/X11/xorg.conf.d/10-monitor.conf
Section "Screen"
   Identifier "Screen0"
   Monitor "Virtual1"
   DefaultDepth 24
   SubSection "Display"
      Modes "1152x864_75.00"
   EndSubSection
EndSection

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-04-10 12:40:05

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: [SOLVED] Small screen size on virtual machine

The command works. Interestingly /etc/X11 doesn't contain xorg.conf.d/ at all???

Offline

#4 2016-04-10 12:40:54

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Small screen size on virtual machine

Peregrino69 wrote:

/etc/X11 doesn't contain xorg.conf.d/ at all???

sudo mkdir -p /etc/X11/xorg.conf.d

wink


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2016-04-10 12:52:44

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: [SOLVED] Small screen size on virtual machine

Duh! tongue big_smile

Unfortunately that didn't do it either...

The only thing I find in vSphere Client settings would be Video memory. Increasing that didn't do work.

I think I'll reinstall this thingy. Also keyboard started acting funny suddenly, layout changed from us to something weird, holding a key down doesn't repeat keystrokes etc...

Offline

#6 2016-04-10 15:08:35

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Small screen size on virtual machine

Peregrino69 wrote:

Unfortunately that didn't do it either...

Ooops, sorry -- I missed a bit  ops

The file should look like this:

Section "Monitor"
   Identifier "Virtual1"
   Option "PreferredMode" "1152x864_75.00"
EndSection

Section "Screen"
   Identifier "Screen0"
   Monitor "Virtual1"
   DefaultDepth 24
   SubSection "Display"
      Modes "1152x864_75.00"
   EndSubSection
EndSection

This works for my QEMU BunsenLabs virtual machine (I have an extra line to add the desired modeline because my VM drivers don't supply that option; your VM does supply that resolution as an option so I don't think you need the extra line).


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2016-04-10 15:18:13

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: [SOLVED] Small screen size on virtual machine

Damn. Creating xorg.conf.d didn't do it even with new installation.

Offline

#8 2016-04-10 15:22:09

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Small screen size on virtual machine

sad

Does adding the `xrandr` command I posted to ~/.config/openbox/autostart work for the openbox session?

Which type of VM are you using?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2016-04-10 16:35:21

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: [SOLVED] Small screen size on virtual machine

Oh, didn't notice the corrected .conf file. Not that it matters, didn't work anyway. I already added the command to autostart, that works just fine. Login screen is still small, but who the heck cares - thanks anyway smile

My guest is running on ESXi 6.0.0. #! and Bunsen are really handy lab test systems as the resource consumption is minimal and whenever a reboot is needed, it happens in no time flat smile For example this one is now running FreeRADIUS, DHCP and DNS. Would be interesting to see how Bunsen would perform in a proper production environment smile

Offline

#10 2016-04-10 18:43:05

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Small screen size on virtual machine

Peregrino69 wrote:

My guest is running on ESXi 6.0.0

I'm not familiar with VMWare but perhaps this link will help:
https://pubs.vmware.com/workstation-9/t … D5734.html


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB