You are not logged in.

#1 2016-02-27 05:56:49

No_windows
Member
Registered: 2016-02-22
Posts: 17

[Solved] Desktop darkening during Synaptic password request.

Hello, first post here in the Muppet Theatre.... er, I mean Bunsenlabs forum!

I'm running Bl on Virtualbox on a Jessie (Xfce) host system.  I've had it installed awhile, and use it from time to time for web browsing and just something to mess around with a bit.....nothing serious.

I've noticed that the screen darkens when the password window appears for Synaptic.  I'm sure this looks great on real hardware, or in a VM with better graphics, but on my limited graphics system it's not a smooth transition.  How can I remove that feature, or turn it off?

My "desktop" computer is a surplus HP rackmount server, so it's graphics capabilities are not the greatest.

Last edited by No_windows (2016-02-27 08:18:29)

Offline

#2 2016-02-27 06:40:46

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,278
Website

Re: [Solved] Desktop darkening during Synaptic password request.

Hi No_windows, welcome to BunsenLabs!

When gksu opens a password box it disables the rest of the desktop as a security precaution. The darkening is presumably to show what's happening, but I don't know any way to change it.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Online

#3 2016-02-27 07:40:06

nobody0
Disabled account
Registered: 2015-09-29
Posts: 664

Re: [Solved] Desktop darkening during Synaptic password request.

^
Is it pkexec or gksu? Most probably pkexec.

Offline

#4 2016-02-27 07:53:54

suomi
New Member
From: Germany, Rhineland
Registered: 2015-10-02
Posts: 2

Re: [Solved] Desktop darkening during Synaptic password request.

Offline

#5 2016-02-27 08:18:09

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

Thank you very much!

gksu-properties

.....and then disable screen grab!  I would have never come up with the right words to search with, to come up with that.

Offline

#6 2016-02-27 10:54:23

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [Solved] Desktop darkening during Synaptic password request.

Hello again No_windows, welcome to the forums smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2016-02-27 23:11:20

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

Ok, further question...... I checked my host Jessie system, and I'm suprised to find screen grabing enabled, yet the screen doesn't darken/flicker.  Is there another control at work here?

Edit:Reading what screen grabing is, it appears to be a security function.  Maybe I should keep it enabled..... but how to defeat the screen changing?  As alluded to above my Jessie install makes me think it's a separate function, and gksu is simply making use of that.

Last edited by No_windows (2016-02-27 23:20:36)

Offline

#8 2016-02-27 23:12:50

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

Head_on_a_Stick wrote:

Hello again No_windows, welcome to the forums smile

Hello, HoaS!

Offline

#9 2016-02-27 23:45:45

vasa1
Member
Registered: 2015-09-29
Posts: 204

Re: [Solved] Desktop darkening during Synaptic password request.

No_windows wrote:

Ok, further question...... I checked my host Jessie system, and I'm suprised to find screen grabing enabled, yet the screen doesn't darken/flicker.  Is there another control at work here?

Edit:Reading what screen grabing is, it appears to be a security function.  Maybe I should keep it enabled..... but how to defeat the screen changing?  As alluded to above my Jessie install makes me think it's a separate function, and gksu is simply making use of that.

The VM v/s bare metal may make the difference?

What about

sudo -H synaptic

instead? On my system, you'll enter the password in the same terminal window as the one you use to run the command. No pretty window with screen darkening, flickering, or otherwise.

Last edited by vasa1 (2016-02-27 23:51:32)


Using the Openbox (3.5.2) session of Lubuntu 14.04 LTS but very interested in BL :)

Offline

#10 2016-02-28 01:10:52

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

vasa1 wrote:

The VM v/s bare metal may make the difference?

I checked my Jessie VM.  It wasn't running when I posted last, but it doestn't even have gksu installed.  I checked and it's using pkexec like was suggested above.

What about

sudo -H synaptic

instead? On my system, you'll enter the password in the same terminal window as the one you use to run the command. No pretty window with screen darkening, flickering, or otherwise.

That does work, but I'd rather not have to open a terminal and type to execute a gui program.  Maybe, I can switch Bl to pkexec.

Offline

#11 2016-02-28 01:44:22

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,278
Website

Re: [Solved] Desktop darkening during Synaptic password request.

No_windows wrote:

That does work, but I'd rather not have to open a terminal and type to execute a gui program.

Also, launching GUI apps with sudo is not recommended, though the -H option might help. (For example, see here, although that was written in the days before pkexec even existed.) 

Maybe, I can switch Bl to pkexec.

Easily done. Open ~/.config/openbox/menu.xml, search for "synaptic" and change the <command> from gksu to pkexec, so the section will look like this:

            <item label="Synaptic Package Manager">
                <action name="Execute">
                    <command>
                        pkexec synaptic
                    </command>
                </action>
            </item>

I've just tested this and it works OK.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Online

#12 2016-02-28 01:58:50

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

johnraff wrote:

Also, launching GUI apps with sudo is not recommended, though the -H option might help. (For example, see here, although that was written in the days before pkexec even existed.)

I did not know that, although it makes sense.  I think I did something like that back when I was very new to Linux, running Kubuntu (11.10 I think).

Maybe, I can switch Bl to pkexec.

Easily done. Open ~/.config/openbox/menu.xml, search for "synaptic" and change the <command> from gksu to pkexec, so the section will look like this:

            <item label="Synaptic Package Manager">
                <action name="Execute">
                    <command>
                        pkexec synaptic
                    </command>
                </action>
            </item>

I've just tested this and it works OK.

Any differance between pkexec synaptic and synaptic-pkexec?  Xfce in Jessie writes it the second way.

Also, is pkexec an internal command of some package, as I can't locate a pkexec package on my system, or on the Debian website.

Last edited by No_windows (2016-02-28 02:02:12)

Offline

#13 2016-02-28 03:16:44

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,278
Website

Re: [Solved] Desktop darkening during Synaptic password request.

synaptic-pkexec is just a little wrapper script that launches synaptic with pkexec:

john@bunsen:~$ which synaptic-pkexec
/usr/bin/synaptic-pkexec
john@bunsen:~$ file $(which synaptic-pkexec)
/usr/bin/synaptic-pkexec: POSIX shell script, ASCII text executable
john@bunsen:~$ cat $(which synaptic-pkexec)
#!/bin/sh
pkexec "/usr/sbin/synaptic" "$@"

To find the package responsible for a certain command on your system you can try 'dpkg -S':

john@bunsen:~$ which pkexec
/usr/bin/pkexec
john@bunsen:~$ dpkg -S /usr/bin/pkexec
policykit-1: /usr/bin/pkexec

so it's in policykit-1


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Online

#14 2016-02-28 04:21:17

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

johnraff wrote:

synaptic-pkexec is just a little wrapper script that launches synaptic with pkexec:

john@bunsen:~$ which synaptic-pkexec
/usr/bin/synaptic-pkexec
john@bunsen:~$ file $(which synaptic-pkexec)
/usr/bin/synaptic-pkexec: POSIX shell script, ASCII text executable
john@bunsen:~$ cat $(which synaptic-pkexec)
#!/bin/sh
pkexec "/usr/sbin/synaptic" "$@"

To find the package responsible for a certain command on your system you can try 'dpkg -S':

john@bunsen:~$ which pkexec
/usr/bin/pkexec
john@bunsen:~$ dpkg -S /usr/bin/pkexec
policykit-1: /usr/bin/pkexec

so it's in policykit-1

Wow, thank you for the answer and demonstration.  I had no idea such tools existed.

Offline

#15 2016-02-28 07:48:38

nobody0
Disabled account
Registered: 2015-09-29
Posts: 664

Re: [Solved] Desktop darkening during Synaptic password request.

Offline

#16 2016-02-28 18:26:20

No_windows
Member
Registered: 2016-02-22
Posts: 17

Re: [Solved] Desktop darkening during Synaptic password request.

ostrolek wrote:

Thank you, I'll take a look...... that looks like what I was hoping to find on the Debian site.

Offline

Board footer

Powered by FluxBB