You are not logged in.

#26 2021-03-21 16:55:34

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

It will not boot for me ??

 21 Mar 21 @ 13:56:28 /media/10/DEBs
   $ ls
conky_1.9.0-4_all.deb  palemoon_29.1.0-1.gtk2_amd64.deb
discord-0.0.13.deb     sha512sum.amd64
dpkg.txt	       sharpbang-buster-10.8.0-amd64.hybrid.iso
 
 21 Mar 21 @ 13:56:34 /media/10/DEBs
   $ sha512sum -c sha512sum.amd64
sharpbang-buster-10.8.0-amd64.hybrid.iso: OK
 
 21 Mar 21 @ 13:56:52 /media/10/DEBs
   $ 

Yet there it is:

 21 Mar 21 @ 13:58:41 /media/sector11/SHARPBANG_BUSTER
   $ ls
autorun.inf  dists    firmware	 install   md5sum.txt  tools
boot	     EFI      g2ldr	 isolinux  pool        win32-loader.ini
debian	     efi.img  g2ldr.mbr  live	   setup.exe
 
 21 Mar 21 @ 13:58:46 /media/sector11/SHARPBANG_BUSTER
   $ 

This new MOBO has jinxed me:

 21 Mar 21 @ 13:59:57 ~
   $ sys
System:    Host: sector11 Kernel: 4.19.0-14-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Openbox 3.6.1 dm: startx 
           Distro: Debian GNU/Linux 10 (buster) 
 
 21 Mar 21 @ 14:00:14 ~
   $ mac
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x serial: <root required> UEFI: American Megatrends 
           v: 5603 date: 10/14/2020 
 
 21 Mar 21 @ 14:00:17 ~
   $ 

The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#27 2021-03-22 13:49:51

unklar
Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,513

Re: [SOLVED] nvidia drivers - and more

^^I would have installed 64-bit x86 buster backports.

because, but you already know that otherwise you can now wait "forever" for the fix   lol  big_smile

Sector11 wrote:
Grave byg of dkms(→ 2.6.1-4) <resolved in some versions>
b1 - #956245 - /etc/kernel/header_postinst.d/dkms: error! You must be root to use this command (fixed dkms/2.8.2-1 dkms/2.8.2-2)

https://forums.bunsenlabs.org/viewtopic … 25#p112625

Offline

#28 2021-03-22 15:29:21

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,278

Re: [SOLVED] nvidia drivers - and more

I don't see the fixed version of dkms available in backports. If it is in some other source, let me know, but I can apply the fix as noted in that bug report for now.

Currently have:

~$ apt policy dkms
dkms:
  Installed: 2.6.1-4
  Candidate: 2.6.1-4
  Version table:
 *** 2.6.1-4 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

Last edited by DeepDayze (2021-03-22 15:32:57)


Real Men Use Linux

Offline

#29 2021-03-24 15:53:32

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

unklar wrote:

^^I would have installed 64-bit x86 buster backports.

As I said here I have it, it checks out "OK" and does not start up let alone install.

Debian SID: dkms (2.8.4-3)
Debian Testing: dkms (2.8.4-3)

Does not seem to be in Debian 10 backports


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#30 2021-03-24 16:27:43

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

unklar wrote:

You could still try

sudo apt install ./dkms_2.8.4-3_all.deb

although other dependencies will certainly run counter.

Looked like it just MIGHT work until I saw:

Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'
 24 Mar 21 @ 13:17:52 ~
   $ cd /media/10/DEBs/test-sid/
 
 24 Mar 21 @ 13:17:59 /media/10/DEBs/test-sid
   $ sudo apt install dkms_2.8.4-3_all.deb
[sudo] password for sector11: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'
The following additional packages will be installed:
  dctrl-tools linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64 linux-kbuild-4.19
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64
  linux-kbuild-4.19
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 10.8 MB/10.9 MB of archives.
After this operation, 59.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
 
 24 Mar 21 @ 13:18:56 /media/10/DEBs/test-sid
   $ sudo apt install dkms_2.8.4-3_all.deb --simulate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'
The following additional packages will be installed:
  dctrl-tools linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64 linux-kbuild-4.19
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64
  linux-kbuild-4.19
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Inst dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Inst dkms (2.8.4-3 local-deb [all])
Inst linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Inst linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Conf dkms (2.8.4-3 local-deb [all])
Conf linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Conf linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])
 
 24 Mar 21 @ 13:19:06 /media/10/DEBs/test-sid
   $ 

So that is a no go.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#31 2021-03-24 18:13:48

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,278

Re: [SOLVED] nvidia drivers - and more

Weird why that would install the old 4.19 kernel packages???


Real Men Use Linux

Offline

#32 2021-03-24 18:21:53

jeffreyC
Member
Registered: 2019-09-07
Posts: 53

Re: [SOLVED] nvidia drivers - and more

But it would install that deb:

Inst dkms (2.8.4-3 local-deb [all])

Conf dkms (2.8.4-3 local-deb [all])

Those show that the local file would be what is installed.
apt is just doing the usual confusing wording that they use.

Offline

#33 2021-03-24 19:00:42

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

No. It is not installing the

dkms_2.8.4-3_all.deb

Re-read this:

Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'

It is going to install:

   $ sho dkms
alias = aptitude show filename
Package: dkms                     
Version: 2.6.1-4
State: not installed
Multi-Arch: foreign
Priority: optional
Section: kernel

And that is the one with the BUG


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#34 2021-03-24 19:09:06

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,278

Re: [SOLVED] nvidia drivers - and more

Sector11 wrote:

No. It is not installing the

dkms_2.8.4-3_all.deb

Re-read this:

Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'

It is going to install:

   $ sho dkms
alias = aptitude show filename
Package: dkms                     
Version: 2.6.1-4
State: not installed
Multi-Arch: foreign
Priority: optional
Section: kernel

And that is the one with the BUG

Why not try to backport the one from Sid?


Real Men Use Linux

Offline

#35 2021-03-25 02:49:40

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

DeepDayze wrote:

Why not try to backport the one from Sid?

To be honest, I'm afraid it will bork my system - again!


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#36 2021-03-25 03:10:32

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,278

Re: [SOLVED] nvidia drivers - and more

Sector11 wrote:
DeepDayze wrote:

Why not try to backport the one from Sid?

To be honest, I'm afraid it will bork my system - again!

If you have another hard drive to try, why not temporarily swap out your daily driver drive and do a test install and do a backport of dkms then test the nvidia driver build again?

To me installing a local package (such as one backported or downloaded) should not cause any side effects other than maybe complaining about dependencies. Something might not be right with your setup.

Another thing to try:

Use dpkg -i <package>. This may complain about missing deps but if you backported the sid package it should (hopefully) install clean. I find that using apt rather than dpkg to install local packages seems to have side effects like this.

Last edited by DeepDayze (2021-03-25 03:17:20)


Real Men Use Linux

Offline

#37 2021-03-25 03:22:28

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,278

Re: [SOLVED] nvidia drivers - and more

I came across this nugget:

https://superuser.com/questions/196864/ … et/1244531

Does this thread help?


Real Men Use Linux

Offline

#38 2021-03-25 03:57:52

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

@ DeepDayze

Key word: IF I have another drive - I do not

aaaa "it should (hopefully) install clean" - I have reinstalled Linux twice now over trying to get this card to work.

I have resigned myself to using the onboard graphics card until the bug is over and done with.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#39 2021-03-25 04:02:10

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

DeepDayze wrote:

I came across this nugget:

https://superuser.com/questions/196864/ … et/1244531

Does this thread help?

Saw that a while back while researching this.  It's 10 years old.
But basically the same stuff - just "apt" now vs "apt-get"


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#40 2021-03-25 08:04:35

unklar
Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,513

Re: [SOLVED] nvidia drivers - and more

DeepDayze wrote:

Use dpkg -i <package>. This may complain about missing deps but if you backported the sid package it should (hopefully) install clean. I find that using apt rather than dpkg to install local packages seems to have side effects like this.

Wrong!
I have been working with sid(uction) for 10 years.
The use of dpkg -i is vehemently rejected there because dpkg does NOT resolve dependencies, unlike apt!

That's why I had written:

You could still try

   

sudo apt install ./dkms_2.8.4-3_all.deb

    although other dependencies will certainly run counter.

S11 just did not understand that he should download this package locally.
Apt will then already tell him what is fact.   smile

Offline

#41 2021-03-25 13:11:58

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

unklar wrote:

S11 just did not understand that he should download this package locally.
Apt will then already tell him what is fact.   smile

Actually I did download the file:

/media/10/DEBs/test-sid/dkms_2.8.4-3_all.deb

I did "$ cd /media/10/DEBs/test-sid/"
and I did run it locally, I will quote it this time:

24 Mar 21 @ 13:17:59 /media/10/DEBs/test-sid
   $ sudo apt install dkms_2.8.4-3_all.deb
[sudo] password for sector11:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'
The following additional packages will be installed:
  dctrl-tools linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64 linux-kbuild-4.19
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64
  linux-kbuild-4.19
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 10.8 MB/10.9 MB of archives.
After this operation, 59.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

24 Mar 21 @ 13:18:56 /media/10/DEBs/test-sid
   $ sudo apt install dkms_2.8.4-3_all.deb --simulate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'dkms' instead of 'dkms_2.8.4-3_all.deb'
The following additional packages will be installed:
  dctrl-tools linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64 linux-kbuild-4.19
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64
  linux-kbuild-4.19
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Inst dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Inst dkms (2.8.4-3 local-deb [all])
Inst linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Inst linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Conf dkms (2.8.4-3 local-deb [all])
Conf linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Conf linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])

24 Mar 21 @ 13:19:06 /media/10/DEBs/test-sid
   $

The only thing I missed was the ./
And have used "apt" over dpkg for about a year now.  Because of something I read.  Do not recall what exactly, maybe for the same reason siduction mentions.


apt gets the file(s) and hands it over to dpkg for the install process.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#42 2021-03-25 16:27:29

unklar
Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,513

Re: [SOLVED] nvidia drivers - and more

Sector11 wrote:

The only thing I missed was the ./

^^This is what tells apt to install the locally available package when you are in the directory of the downloaded package.

The way you show it, apt does not take the locally stored package.
smile  But, your Simultation devil shows something different(!):

Inst dkms (2.8.4-3 local-deb [all])

Therefore, you should try it, because here you get exactly the package you want and the kernel etc., are also updated.  wink

Offline

#43 2021-03-26 00:35:18

jeffreyC
Member
Registered: 2019-09-07
Posts: 53

Re: [SOLVED] nvidia drivers - and more

If you are using Thunar you can add a custom action to install downloaded deb files, like this one:

Install Deb Files

Install deb packages and dependencies with apt

x-terminal-emulator -e bash -c "sudo apt install %F; echo;read -n 1 -s -r -p 'press any key to close'"

Offline

#44 2021-03-26 14:31:23

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

unklar wrote:
Sector11 wrote:

The only thing I missed was the ./

^^This is what tells apt to install the locally available package when you are in the directory of the downloaded package.

The way you show it, apt does not take the locally stored package.
:)  But, your Simultation ]:D shows something different(!):

Inst dkms (2.8.4-3 local-deb [all])

Therefore, you should try it, because here you get exactly the package you want and the kernel etc., are also updated.  ;)

Hmmm So drop to tty2

sector11 login: sector11
Password:
{blah blah blah}
{blah blah blah}
{blah blah blah}
sector11@sector11:~# sudo su -
[sudo] password for sector11:
root@sector11: cd /media/10/DEBs/test-sid/
root@sector11:/media/10/DEBs/test-sid# sudo apt install ./dkms_2.8.4-3_all.deb --simulate

Simulated here:

 26 Mar 21 @ 11:24:08 ~
   $ sudo su -
[sudo] password for sector11: 
root@sector11:~# cd /media/10/DEBs/test-sid/
root@sector11:/media/10/DEBs/test-sid# sudo apt install ./dkms_2.8.4-3_all.deb --simulate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'dkms' instead of './dkms_2.8.4-3_all.deb'
The following additional packages will be installed:
  dctrl-tools linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64 linux-kbuild-4.19
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-headers-amd64
  linux-kbuild-4.19
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Inst dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Inst dkms (2.8.4-3 local-deb [all])
Inst linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Inst linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Inst linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf dctrl-tools (2.24-3 Debian:10.8/stable [amd64])
Conf dkms (2.8.4-3 local-deb [all])
Conf linux-compiler-gcc-8-x86 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-common (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [all])
Conf linux-kbuild-4.19 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-4.19.0-14-amd64 (4.19.171-2 Debian:10.8/stable, Debian-Security:10/stable [amd64])
Conf linux-headers-amd64 (4.19+105+deb10u9 Debian:10.8/stable, Debian-Security:10/stable [amd64])
root@sector11:/media/10/DEBs/test-sid# 

It looks like it is going to work.  Do I need as backported kernel?


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#45 2021-03-26 14:50:37

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

jeffreyC wrote:

If you are using Thunar you can add a custom action to install downloaded deb files, like this one:

Install Deb Files

Install deb packages and dependencies with apt

x-terminal-emulator -e bash -c "sudo apt install %F; echo;read -n 1 -s -r -p 'press any key to close'"

Nice custom action but I prefer manual.

I feel more in (out of) control lol

Please explain: "echo;read -n 1 -s -r -p"

Also no cd to file or "./%F"


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#46 2021-03-26 16:56:02

unklar
Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,513

Re: [SOLVED] nvidia drivers - and more

Sector11 wrote:

It looks like it is going to work.  Do I need as backported kernel?

No.
And if there is, there's always time later.

Offline

#47 2021-03-26 19:06:40

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

unklar wrote:
Sector11 wrote:

It looks like it is going to work.  Do I need as backported kernel?

No.
And if there is, there's always time later.

Will give it a try my friend.
X your fingers for me.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#48 2021-03-26 19:59:09

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

PK, that worked - thank you all .....

 26 Mar 21 @ 16:56:58 ~
   $ sho dkms
alias = aptitude show filename
Package: dkms                     
Version: 2.8.4-3
State: installed
Automatically installed: no
Multi-Arch: foreign
Priority: optional
Section: kernel
Maintainer: Dynamic Kernel Modules Support Team <dkms@packages.debian.org>
Architecture: all
Uncompressed Size: 302 k
Depends: kmod | kldutils, gcc | c-compiler, dpkg-dev, make | build-essential,
         coreutils (>= 7.4), patch, dctrl-tools
PreDepends: lsb-release
Recommends: fakeroot, sudo, linux-headers-686-pae | linux-headers-amd64 |
            linux-headers-generic | linux-headers
Suggests: menu, e2fsprogs
Provides: dh-sequence-dkms, dkms:i386 (= 2.8.4-3)
Description: Dynamic Kernel Module Support Framework
 DKMS is a framework designed to allow individual kernel modules to be upgraded
 without changing the whole kernel. It is also very easy to rebuild modules as
 you upgrade kernels.
Homepage: https://github.com/dell-oss/dkms
Tags: admin::kernel, devel::buildtools, devel::lang:c, devel::library,
      devel::packaging, implemented-in::c, implemented-in::shell,
      interface::commandline, role::devel-lib, role::program, scope::utility,
      suite::debian, works-with::software:source

 
 26 Mar 21 @ 16:57:01 ~
   $ 

Now for nvidia-driver!!!!

Xing fingers.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#49 2021-03-26 20:13:34

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,717

Re: [SOLVED] nvidia drivers - and more

I cannot win this battle....

It wants to install a ton of i386 packages   mad  mad  mad

 26 Mar 21 @ 17:10:47 ~
   $ apt install nvidia-driver --simulate
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gcc-8-base:i386 glx-alternative-mesa glx-alternative-nvidia glx-diversions libatomic1:i386 libbsd0:i386 libc6:i386 libdrm-amdgpu1:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl-mesa0:i386 libegl-nvidia0
  libegl-nvidia0:i386 libegl1:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libgbm1:i386 libgcc1:i386 libgl1:i386 libgl1-mesa-dri:i386
  libgl1-nvidia-glvnd-glx libgl1-nvidia-glvnd-glx:i386 libglapi-mesa:i386 libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2
  libgles-nvidia2:i386 libgles1 libgles1:i386 libgles2 libgles2:i386 libglvnd0:i386 libglx-mesa0:i386 libglx-nvidia0 libglx-nvidia0:i386
  libglx0:i386 libidn2-0:i386 libllvm7:i386 libnvidia-cbl libnvidia-cfg1 libnvidia-eglcore libnvidia-eglcore:i386
  libnvidia-fatbinaryloader libnvidia-glcore libnvidia-glcore:i386 libnvidia-glvkspirv libnvidia-glvkspirv:i386 libnvidia-ml1
  libnvidia-ptxjitcompiler1 libnvidia-rtcore libopengl0 libopengl0:i386 libpciaccess0:i386 libsensors5:i386 libstdc++6:i386
  libtinfo6:i386 libunistring2:i386 libvulkan1:i386 libwayland-client0:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386
  libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386
  libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxshmfence1:i386 libxxf86vm1:i386 nvidia-alternative
  nvidia-driver-bin nvidia-driver-libs nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386 nvidia-egl-common nvidia-egl-icd
  nvidia-egl-icd:i386 nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check
  nvidia-modprobe nvidia-persistenced nvidia-settings nvidia-support nvidia-vdpau-driver nvidia-vulkan-common nvidia-vulkan-icd
  nvidia-vulkan-icd:i386 update-glx xserver-xorg-video-nvidia zlib1g:i386
Suggested packages:
  glibc-doc:i386 locales:i386 lm-sensors:i386 vulkan-utils vulkan-utils:i386

The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#50 2021-03-26 20:24:17

jeffreyC
Member
Registered: 2019-09-07
Posts: 53

Re: [SOLVED] nvidia drivers - and more

Sector11 wrote:
jeffreyC wrote:

If you are using Thunar you can add a custom action to install downloaded deb files, like this one

Nice custom action but I prefer manual.

I feel more in (out of) control lol

Please explain: "echo;read -n 1 -s -r -p"

Also no cd to file or "./%F"

When you right click on the file in Thunar to perform a custom action cd is already taken care of.

I did not invent this custom action, it is from MX Linux, but I think those are the command line switches that cause the terminal readout when the TCA installs the package.

Offline

Board footer

Powered by FluxBB