You are not logged in.

#26 2021-03-07 03:33:43

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,197

Re: Catfish Gtk error

johnraff wrote:
DeepDayze wrote:

looks like d-u-s only breaks on d-x11 if the version of d-x11's version  is below 1.9.10-2. (this is on Sid btw).

~$ apt depends dbus-user-session
dbus-user-session
  Depends: dbus (>= 1.12.20-2)
  Depends: libpam-systemd
  Depends: systemd
  Breaks: dbus-x11 (<< 1.9.10-2~)
  Breaks: policykit-1 (<< 0.105-12~)
  Breaks: udisks2 (<< 2.1.5-2~)
  Recommends: systemd-sysv

Thanks!! How did I miss that yesterday? That same << 1.9.10-2~ is right there on the terminal output I was looking at. roll

On Buster:

~$ apt depends dbus-user-session
dbus-user-session
  Depends: dbus (>= 1.12.20-0+deb10u1)
  Depends: libpam-systemd
  Depends: systemd
  Breaks: dbus-x11 (<< 1.9.10-2~)
  Breaks: policykit-1 (<< 0.105-12~)
  Breaks: udisks2 (<< 2.1.5-2~)
  Recommends: systemd-sysv

(btw 'depends' does not appear in 'man apt' - I guess in this case it's acting as an alias for 'apt-cache depends'.)

Anyway it looks as if we might have to consider whether there is a need for dbus-x11 as well as dbus-user-session in Beryllium. Or maybe those apps that want dbus-launch are finally gone in Bullseye...

Maybe offer d-u-s in Beryllium then if necessary for some apps then users can install d-x11 as a few might still need that (catfish comes to mind for this use case). This may still need some testing no doubt.

Last edited by DeepDayze (2021-03-07 03:35:20)


Real Men Use Linux

Offline

#27 2021-03-07 05:27:06

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,851
Website

Re: Catfish Gtk error

DeepDayze wrote:

This may still need some testing no doubt.

This.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#28 2021-03-07 05:57:49

hhh
Meep!
Registered: 2015-09-17
Posts: 11,448
Website

Re: Catfish Gtk error

johnraff wrote:

Anyway, can anyone confirm whether installing dbus-user-session fixes the catfish startup issue or not?

Confirmed, no logout or reboot required. Let's add it if needed in Bullseye.

Online

#29 2021-03-07 06:06:43

hhh
Meep!
Registered: 2015-09-17
Posts: 11,448
Website

Re: Catfish Gtk error

And it didn't open from the menu after a reboot until I ran it via gmrun first. Let's see how it works on Berrylium, I guess.

Online

#30 2021-03-07 06:49:11

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,851
Website

Re: Catfish Gtk error

hhh wrote:
johnraff wrote:

Anyway, can anyone confirm whether installing dbus-user-session fixes the catfish startup issue or not?

Confirmed, no logout or reboot required. Let's add it if needed in Bullseye.

Well, the one which looks like being the default preference to install on Debian - has been for a while now - is dbus-user-session, so the question is more about whether on Bullseye dbus-x11 will be needed too. Let's hope not.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#31 2021-03-07 22:46:11

dbvolvox
Member
From: England
Registered: 2015-09-29
Posts: 95
Website

Re: Catfish Gtk error

johnraff wrote:

Catfish opens fine for me from the menu on BL Lithium. It was a bit unreliable in the past, agreed. The only thing I can think of that might possibly relate is that I recently installed dbus-user-session.

@dbvolvox if you could try installing that and seeing if it makes a difference? You might have to reboot to see any change. Of course, feel free to remove it afterwards if it doesn't help.

Just confirming latest version of dbus-user-session is already installed.


volvox.biz a very tedious daily account of life during covid,

Offline

#32 2021-03-08 02:16:18

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,851
Website

Re: Catfish Gtk error

^And catfish is still reluctant to start from the menu?
How about if you install dbus-x11 also?


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#33 2021-03-08 23:28:33

dbvolvox
Member
From: England
Registered: 2015-09-29
Posts: 95
Website

Re: Catfish Gtk error

johnraff wrote:

^And catfish is still reluctant to start from the menu?
How about if you install dbus-x11 also?

dbus-x11 is also installed.  Are we sure that programs like Catfish should be able to access the network before File manager use?


volvox.biz a very tedious daily account of life during covid,

Offline

#34 2021-03-09 01:08:33

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,057

Re: Catfish Gtk error

Digging around in upstream, this appears to be fixed in 1.,415 (now 4.15 to more closely reflect XFCE's versioning scheme). It's a python error arising out of version 3.9 python, it seems.
https://gitlab.xfce.org/apps/catfish/-/issues/40

Offline

#35 2021-03-09 01:35:33

hhh
Meep!
Registered: 2015-09-17
Posts: 11,448
Website

Re: Catfish Gtk error

^ So should be fixed in bullseye?

https://packages.debian.org/bullseye/catfish

Online

#36 2021-03-09 02:02:21

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,197

Re: Catfish Gtk error

hhh wrote:

^ So should be fixed in bullseye?

https://packages.debian.org/bullseye/catfish

Works on Sid consistently so it should be fine in Bullseye. The version in Sid is 4.16.0.


Real Men Use Linux

Offline

Board footer

Powered by FluxBB