You are not logged in.

#1 2015-10-01 06:36:51

torq
Member
Registered: 2015-10-01
Posts: 12

[SOLVED] - xfburn error

Hello,
first I want to say thanks to all of you who put in so much work to develop BunsenLabs! I installed the 64Bit version, and it just runs so fast and flawless... well, except this little hickup: when I open xfburn, it says "failed to initialise gstreamer transcoder error occurred setting gstreamer up for transcoding falling back to basic implementation."

Any help or suggestions are very much appreciated, as all solutions I found on the web don't seem to work.

Thanks

Last edited by torq (2015-10-03 11:26:25)

Offline

#2 2015-10-01 16:02:39

hhh
Meep!
Registered: 2015-09-17
Posts: 8,717
Website

Re: [SOLVED] - xfburn error

This is from the RC1 64 bit ISO? I don't currently have that installed, my version ATM is an upgraded alpha2, and I don't think xfburn was included yet. I just installed it from the root menu, no problems.

A search for your message came back with missing gstreamer plugins, you could try re-installing them...

sudo apt-get install --reinstall libgstreamer-plugins-base0.10-0

I'm not going to be able to help much here as I haven't used a CD or DVD in a couple of years now.

Offline

#3 2015-10-01 16:43:47

damo
....moderator....
Registered: 2015-08-20
Posts: 5,246

Re: [SOLVED] - xfburn error

xfburn is in RC1, and I have just reproduced the error, although xfburn starts if run from the terminal:

Failed to initialize gstreamer transcoder: An error occurred setting gstreamer up for transcoding. (falling back to basic implementation)

Reinstalling libgstreamer-plugins-base0.10-0 didn't solve it

Last edited by damo (2015-10-01 16:45:38)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#4 2015-10-01 19:03:31

hhh
Meep!
Registered: 2015-09-17
Posts: 8,717
Website

Re: [SOLVED] - xfburn error

@torq, thanks for reporting this.

@damo, maybe something is missing because the RC1 ISOs are built with --no-install-recommends, but nothing in xfburn's dependencies are striking me as missing. can you try uninstalling/apt-get --purge autoremove/reinstall with recommends and see if the number of packages installed is the same as was removed, and if xfburn starts normally? I have to get ready for work in a minute here.

Offline

#5 2015-10-01 19:14:17

thoro
Member
Registered: 2015-09-30
Posts: 38

Re: [SOLVED] - xfburn error

Well, only a feedback: I'm using xfburn also, but no problems and no error messages so far, whether I start Xfburn directly from the menu or even from the terminal.

thoro@home:~$ uname -a
Linux home 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) x86_64 GNU/Linux

I'm using RC1, installed on hard disc, not in a VM.

Last edited by thoro (2015-10-01 19:28:22)


"It's just your opinion, man!"

Offline

#6 2015-10-01 19:50:36

damo
....moderator....
Registered: 2015-08-20
Posts: 5,246

Re: [SOLVED] - xfburn error

Confirm error in both VBox and HD install, but xfburn still runs after closing the error popup.

`apt-get uninstall/reinstall xfburn` just changes `libburn4 libisofs6 libjte1 xfburn`

Googling suggests that the gstreamer error (on 32bit systems at least) is because the xfburn devs aren't keeping up with gtk development.
I get the same error using Adwaita as well, BTW


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#7 2015-10-02 01:53:46

hhh
Meep!
Registered: 2015-09-17
Posts: 8,717
Website

Re: [SOLVED] - xfburn error

Ah, so we might want to ditch xfburn for something else. I'll make a note.

Offline

#8 2015-10-02 06:51:13

torq
Member
Registered: 2015-10-01
Posts: 12

Re: [SOLVED] - xfburn error

Thanks for your replies... what could be an alternative to xfburn?

Offline

#9 2015-10-02 07:01:13

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] - xfburn error

wodim, perhaps?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#10 2015-10-02 07:03:24

Anaconda
crypto-anarchist
From: Quesnel BC Canada
Registered: 2015-09-29
Posts: 211

Re: [SOLVED] - xfburn error

K3B?

*Anaconda runs for cover*


“The university is well structured, well tooled, to turn out people with all the sharp edges worn off...." Mario Savio
"Protections for anonymous speech are vital to democratic discourse". Help enforce our right to free and anonymous speech by running a Tor relay.

Offline

#11 2015-10-02 09:12:45

pvsage
Internal Affairs
Registered: 2015-09-29
Posts: 1,433

Re: [SOLVED] - xfburn error

^ Just because we're in the Elementary School help forum doesn't mean we should act like toddlers. tongue  Now where did I put that party cannon? monkey

On-topic:  I have had trouble in the past with XFburn, but I can't remember finding an alternative to my liking, since I rarely use optical media anymore.  Does wodim have a relatively friendly GUI now, or is it still command-line and backend?


Be excellent to each other, and...party on, dudes!
BunsenLabs Forum Rules
Tending and defending the Flame since 2009

Offline

#12 2015-10-02 11:32:11

damo
....moderator....
Registered: 2015-08-20
Posts: 5,246

Re: [SOLVED] - xfburn error

xfburn is still working here - it just pops up the error message when starting.

BTW In my jessie netinstall setup, there is no error, so maybe I have other libraries pulled in at some point.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#13 2015-10-02 13:17:55

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: [SOLVED] - xfburn error

Given that it touches gstreamer and stuff perhaps getting that stuff included into the next Live ISO will sort it out. I haven't tracked back the dependency chain but if there is missing gstreamer functionality, that could be cause for the warning.

Offline

#14 2015-10-02 15:47:44

torq
Member
Registered: 2015-10-01
Posts: 12

Re: [SOLVED] - xfburn error

Thanks again, you guys are are the finest i ever came across in a forum. crunchbang and now bunsen, what a great way to go linux!

Offline

#15 2015-10-02 21:17:28

hhh
Meep!
Registered: 2015-09-17
Posts: 8,717
Website

Re: [SOLVED] - xfburn error

I've moved this to Bug reports.

Please sonfirm that running the following removes the error...

sudo apt-get install --no-install-recommends gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly

Offline

#16 2015-10-02 21:32:08

damo
....moderator....
Registered: 2015-08-20
Posts: 5,246

Re: [SOLVED] - xfburn error

hhh wrote:

I've moved this to Bug reports.

Please sonfirm that running the following removes the error...

sudo apt-get install --no-install-recommends gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly

I just installed `gstreamer0.10-plugins-good` and the error has gone away. In a terminal I see

** Message: Using gstreamer transcoder.

Nice one smile


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#17 2015-10-03 01:19:21

hhh
Meep!
Registered: 2015-09-17
Posts: 8,717
Website

Re: [SOLVED] - xfburn error

damo wrote:

I just installed `gstreamer0.10-plugins-good` and the error has gone away.

Confirmed, thanks damo.

Offline

#18 2015-10-03 07:29:23

torq
Member
Registered: 2015-10-01
Posts: 12

Re: [SOLVED] - xfburn error

Great, that did the job. Thanks to hhh + damo.
How can I mark the Problem as 'solved'?

Offline

#19 2015-10-03 10:34:10

pvsage
Internal Affairs
Registered: 2015-09-29
Posts: 1,433

Re: [SOLVED] - xfburn error

^ As the thread OP, you should be able to click an "edit" link for the first post and change the subject line.


Be excellent to each other, and...party on, dudes!
BunsenLabs Forum Rules
Tending and defending the Flame since 2009

Offline

#20 2015-10-03 12:55:11

jonboy
Member
Registered: 2015-10-03
Posts: 14

Re: [SOLVED] - xfburn error

Just come to report this and have seen it has all ready been done, without much of a clue what one to install i installed these,, qtstreamer-plugins, gstreamer1.0-libav, libgstreamer-perl and ruby-clutter-gstreamer and it works.
Regards

Offline

Board footer

Powered by FluxBB